请选择 进入手机版|继续访问电脑版
发新帖

如何安装 processing 模块?

[复制链接]
4176 4

马上注册,结交更多好友,享用更多功能,让你轻松玩转社区。

您需要 登录 才可以下载或查看,没有帐号?立即注册

x
想试试 pathos,貌似已经正确安装,但无法导入,按照作者的提示,看看能否先 import processing,不行,所以尝试先装一下 processing,但是装不了啊,windows 和 linux 下都装不了,提示的错误都一样.这个提示也挺古怪的,我这都 python3.6 了,他却说不支持 2.4 以前的版本.那么这个模块到底怎么安装?百度似乎没任何这方面的帖子
Collecting processingUsing cached processing-0.52.zipComplete output from command python setup.py egg_info:Traceback (most recent call last):File "", line 1, in File "C:\Users\ZLL\AppData\Local\Temp\pip-build-2vtvltpp\processing\setup.py", line 12raise ValueError, 'Versions of Python before 2.4 are not supported'^SyntaxError: invalid syntax
----------------------------------------Command "python setup.py egg_info" failed with error code 1 in C:\Users\ZLL\AppData\Local\Temp\pip-build-2vtvltpp\processing\

举报 使用道具

回复

精彩评论4

dwjgwsm  新手上路  发表于 2018-3-6 20:06:36 | 显示全部楼层
然后试图去下载源码
www.python.org/downloads/
www.lfd.uci.edu/~gohlke/pythonlibs/#pymssql
pypi.python.org/pypi
都找不到这个模块,github 上搜索 processing,1,5000 个相关内容,不知道这模块到底在哪里?

举报 使用道具

回复
dwjgwsm  新手上路  发表于 2018-3-6 20:08:11 | 显示全部楼层
没折腾怎么安装 processing 了,我倒是把 pathos 给安装好了!今天就折腾安装这个模块搞了大半天吧.模块还没有使用,能不能解决我的多进程问题还未知,先说说怎么安装的.这个模块中文网页里面讨论的少.
首先是安装 easy_install,通过它可以安装到最新版本的 pathos,在安装 easy_install 的时候也是出现了一些问题,最好是直接下载最新版的 setuptools 压缩包来安装
然后就是 easy_install pathos
目前是 0.2.2 版

然后在 pycharm 里面导入还是不成功,原因是 pathos 的位置有点特别,需要添加新的搜索路径,可以通过 anaconda 自带 spyder 里面
import sys
print(sys.modules['pathos'])
看到模块的位置,再把这个位置添加到 pycharm 的搜索路径中就行了(注意:路径写到.egg/ 为止,后面的部分不要写了)

setuptools 下载:
https://pypi.python.org/pypi/setuptools
这个帖子里面有一些安装上讨论及使用说明:
https://stackoverflow.com/questions/26059764/python-multiprocessing-with-pathos

举报 使用道具

回复
dwjgwsm  新手上路  发表于 2018-3-6 21:02:46 | 显示全部楼层
顺便说一句,有的时候模块安装看起来没成功,也可能是搜索路径的问题,试试 anaconda 自带的 spyder 导入看行不行?

举报 使用道具

回复
myyou  新手上路  发表于 2018-3-6 21:32:52 | 显示全部楼层
库太老了,只兼容到 python2.4 和 2.5

举报 使用道具

回复
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

快速回复 返回顶部 返回列表